PDA

View Full Version : Charging System Failure



Sleeps_In_Trees
05-07-2007, 01:28 AM
While riding yesterday my volt meter started dropping & quickly bottomed out. Wound up trailering the bike home & putting the battery on a trickle charger. This morning I checked out a few things: Stator pins show good w/zero continuity to ground & less than 1 ohm between them. Both regulator pins show battery voltage to ground, so it's toast, right? After starting the bike I'm only getting 3 VAC between the stator pins at idle & only goes to 5 VAC or so at rev. I just had the stator replaced only 10K miles ago. Looks like the whole charging systemn is fried?? Could a bad regulator have burnt up the stator? WTF??


Any how, which stator/rotor/regulator (to fit my '02 Ultra) is most reliable w/the best warranty?

thanks,

VicW.

Kagan
05-07-2007, 10:04 AM
Unless I'm mistaken, the regulator is fed juice so it can't be the cause.
Yes, stators go bad. That's why we stock them.

I can't help you with the test data, but I'm sure you can rule out the regulator as the culprit.

wreckerman
05-08-2007, 03:47 AM
first in the artiicle section i have a test for your charging system , second if it does need a regulator i recommend excel life time warranty same price as harley , if you need the whole unit then i would go with harley's high out put system a few bucks more then the standard but a lot more power

Sleeps_In_Trees
05-08-2007, 06:32 AM
thanks

VicW.

goodole1
05-07-2008, 02:38 AM
first in the artiicle section i have a test for your charging system , second if it does need a regulator i recommend excel life time warranty same price as harley , if you need the whole unit then i would go with harley's high out put system a few bucks more then the standard but a lot more power

I tried to find the manufacturer of the regulator you speak of, but no dice. Would you please elaborate?

springer-
05-07-2008, 03:00 AM
http://www.accel-motorcycle.com/

goodole1
05-07-2008, 04:01 AM
Thanks