PDA

View Full Version : 06 sportster Nothing/No power/lights/horn



Simpson
07-11-2014, 02:44 PM
I have an issue here I cannot figure out with my 06 sportster. Turn ignition on ..NO power goes to the bike. No horn, lights, NOTHING AT ALL..Battery
*Charged it
*Metered it
*Took it to local shop to have tested
Fuses
*Metered tested - Tested Maxi fuse and all 5 fuses and switch board located under seat on right side
*Pulled each fuse out cleaned off for corrosion
Checked wiring to battery and ground everything looks good tests okay
So my thinking at this point...
Could it be a faulty ignition? If I had an electric diagram it would be a lot easier to test for this.
Is there a security system shut off? I do not have a key fob and if there was I would imagine I could get at least lights.
What am I missing here? Thank you for any and all help.

Wide
07-11-2014, 08:22 PM
You just have to keep doing pin outs until you find it

Yes I have seen Ing switches fail

JD
07-11-2014, 09:39 PM
Buy the service manual with the electronic circuit diagram, it will help you considerably.

Simpson
07-12-2014, 01:24 AM
Wow. After two days of being confused. Rechecked my grounds. the groundwas attached I to the battery and the frame the bike however the bolt on the frame that it was grounded to was loose. Wow problem solved. Thanks

Wide
07-12-2014, 02:28 AM
Awsome !!!

gliderider94
07-16-2014, 06:34 PM
I ALWAYS purchase a service manual for whatever bike I happen to own. Harley does an excellent job in puttying out these manuals. Also, it always helps a little when selling the bike. Working on Harleys isn't all that tuff but there are a lot of tricks and techniques that are made clear by reading the service manual.